Download IBM Optim: Compare User Manual

Transcript
Same Attributes
When the check box is selected, the attributes for Source 1 and Source 2 are
the same. When the check box is cleared, the column attributes for Source
1 and Source 2 tables do not match.
Display Compare File Table Data
To display the rows for a pair of tables listed on the Tables tab:
v Select a pair of tables in the grid, then right-click the pair of tables to display the
shortcut menu. Select Display Rows, then select an option from the cascading
menu to display particular types of compared rows: All → Different → Duplicate
→ Equal → Only
v Double-click a pair of table names in the grid, or select Display Rows from the
File menu. All rows are displayed by default, unless a selection was made on
the Browse tab in Personal Options to limit the display to a particular type of
row (you can select Show Excluded Rows from the Tools menu to display all
rows).
A Browse Compare File Table Data dialog displays data from the selected pair of
tables.
Note:
v If you select more than one pair of tables, several Browse Compare File Table
Data dialogs open. Move one dialog to see other dialogs beneath.
v Binary data is not displayed. Cells containing binary data are shaded. To view
binary data, use the hexadecimal display. For more information about viewing
binary data, see “Display Hexadecimal” on page 86.
Use the Browse Compare File Table Data dialog to review the compared data from
the selected pair of tables. By default, differences in the compared data are shown
in bold, italicized type.
Note: You can select Personal Options to emphasize differences in Source 1 and
Source 2 data.
Table Name
Name of the Source 1 table displays to the left of the toolbar. You can alternatively
display Source 2 table information by selecting Display Source 2 from the toolbar
Options menu.
Side Label Format
In side label format, the column names are displayed down the left side of the
Browse Compare File Table Data dialog and data from Source 1 and Source 2 are
displayed to the right of the headings. Names of the Primary Key column(s) are in
bold type. Side label format focuses on a single row and can display more columns
for the row than the columnar format. Side label format is useful for browsing data
in very wide columns.
Chapter 2. Processing Flow
17