Download Global-WAN
Transcript
<div class="clipw" style="height: 185px; width: 437px;"> <img src="imgs/loan_lan.png" alt="Loan" class="clip loan_1"> </div> See how http://gwan.ch/imgs/loan_lan.png is used in http://gwan.ch/imgs/style.css and http://gwan.ch/index.html. Those two methods have reduced the number of request sent to G-WAN from 20 to 5 for the http://gwan.ch/index.html page, increasing the capacity of the server by a factor 4. GIF has a low overhead and should be used for icons and other small images. PNG works better for larger images because it compresses better but drags more fat. The JPG format should be used with real-world photos. Always reduce the number of colors to the smallest possible power of two (2, 4, 8, etc.) that respects your image palette: doing so will significantly reduce the file size. Supported HTTP features Protocols HTTPS (SSLv2, SSLv3, TLS 1.1 + the TLS 1.2 “server_name” extension or Server Name Indication, see RFC 3546 and 4366), HTTP/0.9, HTTP/1.0, and HTTP/1.1 Methods GET, HEAD, POST (application/x-www-form-urlencoded), PUT, DELETE, OPTIONS (a request can be 4-KB long) Encodings entity, gzip, deflate (encodings are already parsed for handlers / servlets) Conditions: If-[Un]Modified-Since, If-None-Match, If-Not-Match (Etags), If-Range (byte ranges only) Authorization: BASIC and DIGEST, with manual and automatic session support, see the session.c and auth.c samples Others HTTP and servlets caches updated in real-time, directory listings, HTTP compression (deflate, RFC 1950 and gzip, RFC 1952) Supported MIME types “xls”, “tgz”, “tar”, “gz”, “bz2”, “arj”, “rar”, “mp3”, “wav”, “avi”, “mov”, “flv”, ”application/excel” ”application/x-tar-gz” ”application/x-tar” ”application/x-gunzip” ”application/x-bzip2” ”application/x-arj-compressed” ”application/x-arj-compressed” ”audio/mpeg” ”audio/wav” ”video/x-msvideo” ”video/quicktime” ”video/x-flv” © 2007 - 2010 TrustLeap® / Global-WAN® – User’s manual 10/49