Download LogWorks User Manual

Transcript
LogWorks User Manual
© 2004 Innovate Technology, Inc.
1
1
Overview..................................................................................................................... 4
1.1
Specifications...................................................................................................... 4
1.2
Logging engine data............................................................................................ 5
1.3
Logs and Sessions ............................................................................................... 6
2
Using LogWorks......................................................................................................... 7
2.1
Starting up LogWorks......................................................................................... 7
2.2
The LogWorks Main Window ............................................................................ 8
2.2.1
LogWorks Main File Menu ........................................................................ 9
2.2.2
LogWorks Main Input Usage Menu ......................................................... 10
2.2.3
LogWorks Main Input Configure Menu ................................................... 10
2.2.4
LogWorks Main Window Menu............................................................... 10
2.3
Manipulating the Inputs .................................................................................... 11
2.3.1
Configuring the Inputs .............................................................................. 11
2.3.2
Custom Input Lookup Tables.................................................................... 13
3
Working with Logs and Sessions.............................................................................. 16
3.1
The Log Window .............................................................................................. 16
3.2
Log Window Tools ........................................................................................... 17
.............................................................. 17
3.2.1
Hand Tool (Shortcut Ctrl-H)
3.2.2
Overlay scroll tool (Shortcut Alt-H)
................................................... 17
............................................................... 17
3.2.3
Selection Tool (no shortcut)
3.2.4
Measurement tool (Shortcut Ctrl-M)
.................................................. 18
.......... 18
3.2.5
Vertical Magnification Tools (Shortcuts Ctrl- or Ctrl- )
3.2.6
Time Magnification Tools (Shortcuts Ctrl- or Ctrl- )
.............. 18
3.2.7
Real-time Logging Start button (Shortcut Ctrl-N)
............................. 18
3.2.8
Playback button (Shortcut Ctrl-Spacebar)
.......................................... 18
3.2.9
Stop button (Shortcut Ctrl-Spacebar)
................................................. 18
3.2.10
Pause button (Shortcut Pause-key)
..................................................... 18
3.3
Log Window File Menu.................................................................................... 19
3.3.1
Record new Session .................................................................................. 19
3.3.2
Playback Session....................................................................................... 19
3.3.3
Pause Record/Play .................................................................................... 19
3.3.4
Save…....................................................................................................... 19
3.3.5
Save As… ................................................................................................. 19
3.3.6
Print…....................................................................................................... 19
3.3.7
Close ......................................................................................................... 20
3.4
Log Window Edit Menu ................................................................................... 21
3.4.1
Copy.......................................................................................................... 21
3.4.2
Paste as Overlay........................................................................................ 21
3.4.3
Paste as new session.................................................................................. 21
3.4.4
Remove Overlay ....................................................................................... 22
3.4.5
Autoselect… ............................................................................................. 22
3.4.6
Go to next selection .................................................................................. 22
3.4.7
Select whole session ................................................................................. 22
© 2004 Innovate Technology, Inc.
2
3.4.8
Delete Selection ........................................................................................ 22
3.5
Log Window Session Menu.............................................................................. 23
3.5.1
Show Session Info..................................................................................... 23
3.5.2
Delete current session ............................................................................... 23
3.5.3
Session selection ....................................................................................... 23
3.6
Log Window Input Menu.................................................................................. 24
3.7
Log Window Tools Menu................................................................................. 25
3.7.1
Tool Selections.......................................................................................... 25
3.7.2
Delete Measurements................................................................................ 25
3.7.3
Show Legend ............................................................................................ 25
3.8
Log Window View Menu ................................................................................. 26
3.8.1
Cascade Windows..................................................................................... 26
3.8.2
New X-Y Plot… ....................................................................................... 26
3.8.3
X-Y Plots .................................................................................................. 27
3.8.4
Statistics… ................................................................................................ 28
3.8.5
View Chart… ............................................................................................ 29
4
Summary of Shortcuts............................................................................................... 31
4.1
LogWorks Main Window ................................................................................. 31
4.2
Input Configuration and Lookup Table ............................................................ 31
4.3
Log Window ..................................................................................................... 31
4.3.1
Real-Time log control ............................................................................... 31
4.3.2
Saving/Printing ......................................................................................... 31
4.3.3
Tool shortcuts............................................................................................ 32
4.3.4
Selections/Search ...................................................................................... 32
4.3.5
Copy/Paste/Delete..................................................................................... 32
4.3.6
Overlay shortcuts ...................................................................................... 32
4.3.7
Scrolling shortcuts .................................................................................... 32
4.3.8
Magnifying shortcuts ................................................................................ 32
4.3.9
Selection tricks.......................................................................................... 33
5
Tips & Tricks for using LogWorks........................................................................... 34
6
Revision History ....................................................................................................... 36
© 2004 Innovate Technology, Inc.
3
1 Overview
LogWorks is a software application that interfaces with the LM-1 digital Lambda Meter and other
Innovate Motorsports' products. It enables easy analysis and manipulation of engine data
acquired by the auxiliary input capabilities of the LM-1. With the appropriate firmware in the LM-1
this software package also allows view engine data in real-time on the on-screen virtual gauges.
1.1
Specifications
Computer requirements
Operating System
Computer speed
RAM
Hard Disk space
Display
Other
Windows 95 or later
300MHz Pentium 1 or faster
Min. 48 Mbyte
Min. 100 Mbyte free space
Thousands of colors, 800 x 600 Min.
1 free serial port or USB to serial adapter
LM-1
Firmware version required
LM-1 Input Impedance
LM-1 Dynamic Input Impedance
Data logging rate
LM-1 Max. Logging time internally
LM-1 Max number of sessions intern.
1.1 (1.33b or later recommended)
> 1 MOhm (- 0.5 to + 5.5V input range)
< 10 kOhm (< - 0.5V or > 5.5V input range)
Low pass filter 10 kOhm / 4700 pF
12.21 times/second for all inputs concurrently
Equivalent to 81.92 msec per data set
44 minutes
1024
LogWorks limits
Max. Session Size
Max. Number of sessions per log
Max. Number of logs open
© 2004 Innovate Technology, Inc.
1 hr 45 minutes
1024
32 open concurrently
4
1.2
Logging engine data
The LM-1 unit has 5 analog inputs for datalogging external signals. These inputs have a
capability to digitize signals between 0 Volt and 5 Volt. The input signal is converted by an
analog-to-digital converter in the LM-1 into a number between 0 and 1023 or a total of 1024 steps
incl. 0. This is equivalent of a 10 bit resolution (210 = 1024). The resulting resolution is therefore
about 4.9 mV. Any signal variations smaller than that cannot be resolved.
Because the LM-1 measures the input signal relative to its internal ground, differences in grounds
between the signal source (sensor) and the internal ground of the LM-1, will show up as shifts in
the digitized signal. LogWorks has features to allow compensating for these potential differences.
Voltages are very seldom required to analyze engine data. Other quantities like throttle position
(TPS), RPM, manifold pressure (MAP), exhaust temperature (EGT) or cylinder-head temperature
(CHT) and so on are more useful. Specialized sensors in the engine typically convert these
quantities into a voltage that can be used by the fuel-injection computer and also by the LM-1
analog inputs. LogWorks has capabilities to convert the logged number back to the original
quantity, provided the characteristics of the original sensors are known. This means that
LogWorks needs to know how to convert the voltage output of the original sensor to the
measured quantity equivalent.
The Air-Fuel-Ratio signal of the LM-1 is not digitized from an external analog voltage. Instead it is
internally calculated. For logging purposes this signal is internally always stored as Lambda with
a resolution of 10 bits (1024 steps). To create the Air-Fuel-Ratio, the Lambda value is multiplied
with the stoichiometric ratio for the given fuel (like 14.7 for gasoline) by the LogWorks software.
The datalog range for Lambda is 0.5 to 1.523, equivalent to 1024 steps with a resolution of 0.001
Lambda (for gasoline this is equivalent to a 0.0147 AFR with a range of 7.4 to 22.4 AFR). This
range is more than sufficient for spark ignited internal combustion engines. AFR/Lambda ranges
outside of the logging range are pegged at the minimum or maximum point respectively.
© 2004 Innovate Technology, Inc.
5
1.3
Logs and Sessions
Different to other datalogging products, LogWorks organizes the acquired data in logs and
sessions. A session is a contiguous data set. This means there is no interruption in the data
stream and all data points are spaced equally in time (81.92ms apart). Each time you start
logging a new session is created and the session ends when the logging stream is stopped.
A log is a collection of sessions. In a typical qualifying race or tuning session multiple runs are
made, and each run is datalogged. LogWorks conveniently organizes these runs into a common
log. The sessions in a log are numbered from 1 through x. Typically they are sequential in time,
starting with the oldest session as session 1 and so on. Each log can be stored in a separate file
on the computer.
In addition each log contains the information how to convert the digitized numbers (see Logging
engine data) into the original quantities. These so called input settings apply to all sessions in a
log.
LogWorks distinguishes three different kinds of logs:
a)
Real-time log
This is a log created by connecting the LM-1 serial port to a computer and recording the real-time
data stream from the LM-1. New sessions can be added at any time by starting to record the
serial stream. Real-time logs require LM-1 firmware version 1.33b or later.
Only one real-time log can be open at any time.
The current real-time input settings apply to the real-time log.
b)
LM-1 log
This is a log created by downloading log data from the LM-1’s internal memory, but not yet stored
in a file. Only one LM-1 log can be open at any time.
The current real-time input settings apply to LM-1 log.
c)
File logs
File logs are data files created by LogWorks when saving a real-time log or a LM-1 log. Up to 30
such logs can be opened by LogWorks concurrently. LogWorks stores logs in either of two file
formats:
Log files (file extension .log)
Or
DIF files (file extension .dif)
The .log file format is native to LogWorks. It stores the original data in a very compact format and
also stores additional information like measurement points, filter parameters and all input settings.
This allows to change and manipulate the data later more conveniently than the DIF file format.
The DIF file format is used to allow importing the log data into spreadsheet program like Microsoft
Excel.
© 2004 Innovate Technology, Inc.
6
The DIF format stores the data as manipulated by LogWorks and already converted into the real
engine quantities. Because of that, information can be lost when reloading a DIF file for further
manipulation.
The DIF format should only be used when the log data is to be processed by external software
like Excel.
2 Using LogWorks
2.1
Starting up LogWorks
Connect your LM-1 serial port to a free serial port on your computer and start the LogWorks
program. The LM-1 can either be currently operating in the car or can be connected (running from
its internal battery) to the computer. Real-time logging can of course only be done when running
the LM-1 in the car.
The following dialog box will appear:
Select the serial port (COM Port) to which the LM-1 is connected. Then press the Connect button.
To quit here and don’t start LogWorks press the Quit button.
If you do not wish to connect to the LM-1 (or don’t have it connected), Press the “Don’t connect”
button.
Check the “Connect on this port in the future” checkbox if you want to auto-connect on the
selected port always in the future (you can change that later on if you wish).
LogWorks can also be started by dragging one or more log files on the LogWorks icon (if you
installed one on the desktop). In this case the log files will be opened automatically.
Make sure no other program (including LM Programmer or LM-1
Manager) is using the selected serial port.
© 2004 Innovate Technology, Inc.
7
2.2
The LogWorks Main Window
After this the main window of LogWorks, the LogWorks Monitor, appears:
This window is resizable by grabbing on the lower edge of the window. The round gauges are
typically arranged in a 3 x 2 arrangement. This arrangement will be changed depending on the
window width and height to maximize the gauge size. All gauges are grayed out until:
a) LogWorks is connected to the LM-1
b) A valid serial data stream is detected on the serial port
c) The appropriate input is enabled.
When this happens the window might look like this:
© 2004 Innovate Technology, Inc.
8
2.2.1 LogWorks Main File Menu
Connect…
Allows the connection of LM-1 on the serial port if LogWorks was started without connecting.
Auto-connect on start
Allows auto connecting at LogWorks start to be switched off or on.
New Real-time Log…
Starts a new real-time log or brings the real-time log window to the front if it is already open.
Download LM-1 Log…
Creates a new LM-1 log by downloading data internally logged in the LM-1. During downloading
the car may not be running (engine off) because the WB sensor’s heater is switched off during
downloads. After a download completes, the LM-1 is automatically restarted (heater runs again).
Open File Log…
Opens a saved log for further inspection and manipulation.
Import Input description…
Extracts the input settings data from an existing log file. Note that .dif files do not contain the
entire input description data.
Save Input description…
Saves the current input settings (see Configuring the Inputs) in a .log file. This log file will contain
only the input settings, no session data. Trying to open it as a file log results in an error.
Reset LM-1 Log
Resets the log memory in the LM-1. This works only in LM-1 firmware version 1.33b or later.
© 2004 Innovate Technology, Inc.
9
2.2.2 LogWorks Main Input Usage Menu
Allows selectively switching inputs off that are not connected or not used for datalogging. The
appropriate gauge is grayed out when switching the input off and the data from that input is not
used or shown in the real-time log or LM-1 log.
2.2.3 LogWorks Main Input Configure Menu
The first two items allow you to select if Lambda data from the LM-1 is to be shown as Lambda or
air-fuel-ratio (AFR).
The other items allow you to custom configure each input. See Configuring the Inputs.
2.2.4 LogWorks Main Window Menu
Use this menu to quickly switch between open logs.
© 2004 Innovate Technology, Inc.
10
2.3
Manipulating the Inputs
2.3.1 Configuring the Inputs
The Configure Menu of the main window allows configuring the LM-1 inputs. The AFR/Lambda
input can’t be configured. You can only switch it between displaying Lambda or AFR. To
configure an input, select the appropriate input from the Configure menu or double-click on the
appropriate instrument. The following dialog box appears:
This dialog box contains 5 fields.
Field 1.
In field one you can specify a name for the input for easy identification. The left side of this field
shows a colored box. This color is the trace color of this input in the logs.
The following (case sensitive) names can NOT be used to name an input:
RPM
TEMP
DWELL
PRESS
ACCEL
These names are reserved for inputs from the Aux-Box or RPM converter.
© 2004 Innovate Technology, Inc.
11
Field 2.
Field 2 is used when using the Aux-Box or RPM converter. It allows you to specify whether the
appropriate input of the Aux-Box/RPM converter is used and on which setting. The actual settings
for the Aux-Box or RPM converter are shown in the grayed out items of Field 4.
Field 3. and 4.
The buttons in this field allow you to create your custom conversions from voltage to the
appropriate quantity measured.
The voltage/sample buttons are simple. The log will just contain the voltages measured or the
appropriate sample number (a number between 0 and 1023, equivalent to 0..5V).
Clicking the “Custom Conversion” button allows you to specify in Field 4 the unit measured (PSI
in the above example) and two voltages (0 and 5V in the above example) and the equivalent
measurement quantity ( - 14.7 and 29.4 PSI respectively in the example). If voltages different
than 0 and 5V are specified, the range will be automatically expanded to 0..5V, even if the sensor
is not capable to produce 0..5V (the measured signal will stay within the range the sensor
produces).
The Load/Edit table button allows you to import or create a custom lookup table for the input.
More on that later.
Field 5.
This field only affects the display of the gauges in the LogWorks Monitor window.
This allows you to specify either no markings, a single mark (a red line) or a red-line area in the
gauge as in the resulting example:
Note:
If this dialog box was started from the LogWorks main window, a real-time log window or
the LM-1 log window, right clicking on one of the ‘equivalent to’ voltage input fields will
show a menu that allows you to paste the current input voltage of this input.
© 2004 Innovate Technology, Inc.
12
2.3.2 Custom Input Lookup Tables
Press the Load/Edit Table button in field 3, and you will be presented with the following dialog
box:
Double click on any field in the table to modify it. Click on a field to select it. To delete an entry,
select it and hit the delete key.
If you make changes by editing, click anywhere in the table to make the changes
permanent.
You can import a new lookup table from a text file (extension .txt) or a DIF file created by a
spreadsheet program (extension .dif). A text table must have two columns, separated by spaces
or tabs.
The first line contains in the left column the unit of the measured quantity (PSI in our example).
The right column, first line must contain the word “Volt”.
Underneath that first line listed are the individual equivalents of the lookup table. Left column
contains the measured quantity and the right the equivalent voltage.
Note:
The slider on the left of the window shifts the entire table voltages up or down to
compensate for ground differences between LM-1 and the measurement sensor.
© 2004 Innovate Technology, Inc.
13
The following is an example of an input lookup table:
PSI
-14.7
-10.0
0
5
15
29.4
Volt
0.1
1.2
2.1
2.8
4
4.9
A DIF file must be organized similarly. The top left entry in the spreadsheet (field A1) must
contain the measured unit. The second entry (field B1) MUST contain the word “Volt”. The rest of
the ‘A’ column contains the measured quantity equivalents and the rest of the ‘B’ column contains
the equivalent voltages.
When loading the table LogWorks sorts it in ascending order by voltage. LogWorks then creates
a custom lookup table for all 1024 possible input values by linearly interpolating between table
points. The table must be monotone rising or falling. If the difference between the second
quantity and the first quantity is positive, the quantities must be always rising (third bigger than
second and so on. If the difference is negative, the quantities must be always falling (third smaller
than second and so on). If this were not the case, the same voltage could mean different
measured quantities.
Example of monotone lookup table (x in PSI, y in Volt):
6
5
4
3
2
1
0
-20
-10
0
10
20
© 2004 Innovate Technology, Inc.
30
40
14
An example of a wrong table:
3
2.5
2
1.5
1
0.5
0
-20
-10
0
10
20
30
40
Note that 2.1 V could either mean 0 PSI or 15 PSI.
Note1:
Different than the custom setting in Field 3. of the Input Settings dialog box, the lookup
table will NOT be automatically expanded to 0..5V. Instead the resulting log is clipped
to the minimum and maximum of the table entries.
Note2:
If this dialog box was started from the LogWorks main window, a real-time log window
or the LM-1 log window, double-clicking on one of the voltage fields, then right clicking
on it will show a menu that allows you to paste the current input voltage of this input.
© 2004 Innovate Technology, Inc.
15
3 Working with Logs and Sessions
3.1
The Log Window
The Log window can be resized to any size. It is divided into different areas:
1. Menu area
Contains the Log menus.
2. Tool area.
Allows selecting the various tools and functions to manipulate the log
3. Active trace selection
Select the input to which the manipulations apply. Click on the button to pop-up a menu of the
active traces/inputs.
4. Vertical scale
Shows the vertical scale of the graph for the currently active input.
5. Graph area
Shows the graphs of the active traces color coded. This is the same color as shown in the input
configuration menu described in Configuring the Inputs field 1.
6. Measurement point
Any number of measurement points can be inserted in a graph. The measurement points scroll
with the graph. A measurement point shows the values of all active inputs at that particular point
in time.
© 2004 Innovate Technology, Inc.
16
7. Legend
Shows the names of the input traces and their respective color. The legend can be switched on
and off. By default it is off.
8. Smoothing filter
The smoothing filter slider allows smoothing an input trace by replacing each data point with the
running average of its neighbors and itself. The position of the slider determines how many of the
neighbors are included in the running average (0 to 32 neighbors on each side).
9. Scroll slider
Selects which portion of a session is visible in the graph.
10. Time scale
11. Session length info
Shows the total length of the session.
3.2 Log Window Tools
Select the tool by clicking on it. You can also switch between tools using a keyboard shortcut.
3.2.1 Hand Tool (Shortcut Ctrl-H)
Scroll the graph left and right. If the current trace is vertically magnified (see vertical magnification
tools) also scrolls the graph up or down. To scroll, click in the graph (left mouse button) and drag
the graph left or right.
If the active trace is vertically magnified, right clicking anywhere on the graph centers the trace.
If a real-time session is currently recording, the graph will automatically scroll to show the latest
data. Scrolling with the hand-tool or the horizontal scroll bar to an earlier time in the recording will
stop the auto scrolling. To restart auto scrolling, scroll the graph to the rightmost end.
3.2.2 Overlay scroll tool (Shortcut Alt-H)
When an overlay is pasted onto a session, this tool moves the overlay relative to the underlying
graph. To scroll, click in the graph (left mouse button) and drag the overlay left or right.
3.2.3 Selection Tool (no shortcut)
Allows selecting a portion of a session. To select a portion, click in the graph (left mouse button)
and drag the mouse left or right. Whenever you click (without any other keys held down), the
current selection is removed. Holding down the shift key while clicking extends the selection from
the first click to the new click.
Holding down the Ctrl key while clicking allows selecting multiple areas without removing the
previous selection.
© 2004 Innovate Technology, Inc.
17
3.2.4 Measurement tool (Shortcut Ctrl-M)
Use this tool to add measurement points in the graph as shown in item 6 of the window.
Click anywhere in the graph to add a measurement point. Click in the measurement window
(rectangular area showing the measurement results) to remove a measurement point. Click and
drag to fine-position a measurement point. Any number of measurement points can be added.
When holding down the Ctrl-key while releasing the mouse button, the measurement point is
considered temporary and will be removed.
3.2.5 Vertical Magnification Tools (Shortcuts Ctrl-
or Ctrl- )
These tool buttons are used to increase or decrease the vertical magnification of the active trace
to see fine details. The trace can be magnified up to 16 times.
3.2.6 Time Magnification Tools (Shortcuts Ctrl-
or Ctrl- )
These tool buttons are used to increase or decrease the horizontal or time magnification of the
session to see fine details. The time scale can be expanded up to 32 times.
3.2.7 Real-time Logging Start button (Shortcut Ctrl-N)
This button is only visible in the real-time session window. Clicking this button starts a new realtime session.
3.2.8 Playback button (Shortcut Ctrl-Spacebar)
This button starts playback of the current session on the LogWorks main window. The gauge
settings reflect the settings of the playing log during playback. Playback always starts at the left
edge of the current session window. If areas in the session are selected, only the selected areas
will be played back.
3.2.9 Stop button (Shortcut Ctrl-Spacebar)
Clicking this button stops recording a real-time session or stops playback.
3.2.10
Pause button (Shortcut Pause-key)
Clicking this button pauses recording/playback. When recording, the log window will not be
updated, but recording continues in the background. Click the button again to un-pause and
resume updating of the log window.
© 2004 Innovate Technology, Inc.
18
3.3
Log Window File Menu
3.3.1 Record new Session
Starts/Stops a real-time session. Same as Real-time Session Start button.
3.3.2 Playback Session
Starts playback of the current log. Same as playback or Stop button.
3.3.3 Pause Record/Play
Pauses the real-time recording. Same as Real-time Session Pause button.
3.3.4 Save…
Saves the log into a log file. Either as .log or as .dif file.
3.3.5 Save As…
Saves the log under a different file name.
3.3.6 Print…
Prints the log or current session. A print dialog box like below appears:
© 2004 Innovate Technology, Inc.
19
This dialog is divided into four sections:
In the ‘Printer’ section select the printer to use. Usually you do not need to touch this section.
The ‘Print range’ section allows you to select the time range you want to print.
The ‘Presentation’ section allows you to select if you want to show the time-scale or vertical
scales for each input expanded as in the window or at their normal scale.
Check the ‘Print Black and White only’ button if you do not print on a color printer.
The ‘Show vertical scales’ section allows you to select if you want to show the vertical scale on
the left of the graph on every page or only on the first one, or if you want to show the scales for all
traces or only for the input-of-interest trace. The input-of-interest trace (the one currently selected
in the graph display) will always be shown next to the graph and the grid-lines represent divisions
of that trace.
3.3.7 Close
Closes the log window.
© 2004 Innovate Technology, Inc.
20
3.4
Log Window Edit Menu
3.4.1 Copy
Copies a selection (see Selection Tool) into the LogWorks internal clipboard.
3.4.2 Paste as Overlay
Pastes the clipboard content on top of the current session as overlay. The traces of the overlay
are shown as dashed instead if solid as in the example below:
Using the overlay scroll tool you can move the overlay left and right. If a measurement point
overlaps an overlay trace, the overlay measurements at this point are shown in brackets (). The
hand tool or horizontal scroll bar moves underlying graph and overlay together. Overlays are not
saved with a log.
3.4.3 Paste as new session
You can only paste a session or part of a session into an existing log from another log. Not within
the same log. The input definitions of the source and destination logs have to match.
© 2004 Innovate Technology, Inc.
21
3.4.4 Remove Overlay
Removes the overlay.
3.4.5 Autoselect…
Autoselect is a very powerful tool to select areas of interest in a session. Selecting this item
brings up the following dialog box:
In the window of this dialog box you can specify up to 32 search terms like “AFR > 14.7” and so
on. You can then connect these terms with ‘AND’ or ‘OR’. LogWorks will process the entire
session and select those areas which satisfy the search criteria. In the above example all lean
spots leaner than 14.7 AFR are selected where the engine is under boost and the throttle position
is bigger than 60%. You do not have to specify a unit (like % after 60% or PSI after 0 PSI).
Note that the input names are case sensitive. Afr would be different than AFR. Make sure you
type the input name correctly.
3.4.6 Go to next selection
This menu item (equivalent to a search function) jumps directly to the beginning of the next
selection created by for example the Autoselect function. It also puts a temporary measurement
point at that point.
3.4.7 Select whole session
Equivalent to the select all function of other programs. Selects the entire session.
3.4.8 Delete Selection
Deletes the selected area from a session. Note that only areas at the beginning or end of a
session can be deleted. Deleting in the middle would cause a non-contiguous data area and is
therefore not allowed.
© 2004 Innovate Technology, Inc.
22
3.5
Log Window Session Menu
3.5.1 Show Session Info
Shows information about the session:
Session length (in minutes and seconds)
Record start time and date (only for real-time sessions).
3.5.2 Delete current session
Deletes the current session from the log. If only one session is left, it cannot be deleted (logs
can’t be empty).
3.5.3 Session selection
Select which session you want to view/manipulate.
© 2004 Innovate Technology, Inc.
23
3.6
Log Window Input Menu
This menu allows switching mixture display between AFR and Lambda. It also allows selectively
switching input traces on and off and configuring the inputs.
The input configuration is described in Manipulating the Inputs.
Input configuration changes performed in the real-time log window also apply to the LogWorks
main window and vice versa. The same is true for the LM-1 log window.
File log input changes only affect the current file log.
© 2004 Innovate Technology, Inc.
24
3.7
Log Window Tools Menu
3.7.1 Tool Selections
The Hand Tool, Selection Tool, Measure Tool and Scroll Overlay selections are the same as
described in the Log Window Tools chapter.
3.7.2 Delete Measurements
Deletes all measurement points in the current session.
3.7.3 Show Legend
Shows/Hides the legend window.
© 2004 Innovate Technology, Inc.
25
3.8
Log Window View Menu
3.8.1 Cascade Windows
This item causes all auxiliary views of the session (Statistics Window or X-Y Plot Window, see
below) to be stacked in the top left corner of your screen.
3.8.2 New X-Y Plot…
This opens a new X-Y Plot window. An X-Y plot window shows the data of any two inputs in a
two-dimensional graph like this:
In this case the Y-axis is AFR and the X-axis is RPM. You can select any two inputs as either of
the X or Y axis. If nothing in the graph is selected, the X-Y Plot represents the data of the entire
session. If a part of the session is selected (Selection Tool), only the data of the selected areas is
represented.
For example if you are only interested in the AFR over RPM curve for wide open throttle (WOT),
you can either hand-select these areas or use the Autoselect tool if you have a throttle position
input connected to the LM-1.
As shown above the individual data points are shown as small "x"s. Clicking the ‘----‘ button
shows the data connected with lines as in this:
© 2004 Innovate Technology, Inc.
26
In either case measurement points in the graph are represented by black + marks.
The X and Y axis are automatically scaled to the range of input values for the respective axis.
Manipulating the session data with the smoothing filter, changing selection or adding/deleting
measurement points will be automatically represented in the X-Y Plot.
3.8.3 X-Y Plots
This submenu lists all open X-Y Plot windows and allows you to quickly bring one to the top.
© 2004 Innovate Technology, Inc.
27
3.8.4 Statistics…
This submenu opens a statistics window for the selected input. A statistics window looks like this:
This window shows how often a certain input value happened during a session or partial session.
If nothing in the graph is selected, the Statistics window represents the data of the entire session.
If a part of the session is selected (Selection Tool), only the data of the selected areas is
represented.
The vertical axis is automatically scaled relative to the highest occurrence. The horizontal axis is
automatically scaled to the range of the input with the session or selection.
In addition the window shows how many data points (time) are represented, the average of the
selected data and the minimum and maximum points in the selected data range or entire session.
Manipulating the session data with the smoothing filter, changing selection or adding/deleting
measurement points will be automatically represented in the statistics.
© 2004 Innovate Technology, Inc.
28
3.8.5 View Chart…
This item creates a 3D chart that looks like this:
This example shows average AFR over throttle position and RPM.
Setting Columns and Rows
The Columns/Rows menus allow you to select any input as the horizontal/vertical axis of the
chart. You can also specify the step size and start value. Select the “Set Step size” item in the
Columns or Rows menu. The following dialog box will show up:
This allows you to set the start value and step size of each axis.
Printing/Saving
These choices in the file menu are obvious. The chart is saved as .dif file so it can be easily
imported into a spreadsheet.
© 2004 Innovate Technology, Inc.
29
Chart Views
In the view menu you can select if you want to see the average, standard deviation, min/max
values and number of data points contributing to each field in the chart.
You can also elect to create the chart from all sessions in the log or only from the current session.
If the current session is viewed only, but areas in the session are selected, the chart will reflect
only the selected areas.
Working with charts
You have to be careful when using the chart for tuning the main fuel map of your EFI system. The
chart reflects what’s in the log, including transition points and so on. So acceleration enrichment
and possible warm-up enrichment are reflected in the averages as well. The best way to create a
chart is to create an as long log as possible with steady load points. This way the effects of
transitions are minimized. The fewer data points are represented, the less reliable the data. This
is reflected as well in the standard deviation.
Double-Clicking on a field in the chart brings up the following dialog box:
This shows the current values of the clicked field. The target AFR or Lambda calculation functions
are only available if the field content is AFR or Lambda. The fueling change calculation is based
on fuel flow control where higher numbers represent more fuel. If for example your EFI is set by
injector timing, just multiply the timing setting by the suggested number.
This number is a suggested value only, different EFI systems will react differently.
During real-time logging the chart will be updated in real-time as well. The currently updating field
is highlighted. This allows to ‘drive by load point’ to make sure you are filling all the chart fields.
Acceleration runs in low gears are not ideal for calculating the load points. The same problem as
in inertial dynos exists. The acceleration enrichment might still be active and reliable load point
data can't be extracted from only a few data points.
© 2004 Innovate Technology, Inc.
30
4 Summary of Shortcuts
Shortcuts are keyboard sequences or mouse-clicks that allow you to quickly perform a function
without selecting a menu item or clicking a button.
Keyboard shortcuts usually involve a modifier key like Ctrl, Alt or Shift.
To perform the shortcut, hold down the modifier key and then press the shortcut key.
Example:
Ctrl-N means hold down the Ctrl key and then press the N-key.
Alt-O means hold down the Alt key and then press the O-key.
Other shortcuts in this section contain Mouse button clicks (usually left mouse button) together
with holding down a modifier key.
Some shortcuts are performed by clicking the right mouse button or pressing a special key.
Double clicks means that you click the left mouse button twice rapidly.
4.1
LogWorks Main Window
Ctrl-L
Ctrl-N
Ctrl-D
Double-click dial
Pause key
Connect to the LM-1 for real-time logging/monitoring if not connected
Start a new real-time log
Download a log from the LM-1
Configure this input
Freezes/Unfreezes the gauge displays
4.2 Input Configuration and Lookup Table
Rick click on
Voltage input
field
4.3
Brings up a popup-menu (real-time settings only) that allows to insert the
current input voltage in the field
Log Window
4.3.1 Real-Time log control
Pause key
Ctrl-N
Ctrl-Spacebar
Pause real-time logging
Start real-time logging
Stop logging/playback or start playback
4.3.2 Saving/Printing
Ctrl-S
Ctrl-P
Save the log
Print the log/session
© 2004 Innovate Technology, Inc.
31
4.3.3 Tool shortcuts
Ctrl-H
Ctrl-M
Alt-H
Ctrl-L
Ctrl- left mouse
up
Switch to Hand Tool
Switch to Measure Tool
Scroll Overlay tool
Hide/Show Legend
Delete current measurement point, making it temporary
4.3.4 Selections/Search
Ctrl-F
Ctrl-G
Ctrl-A
Start the Autoselect function
Jump to the next selection
Select the whole session
4.3.5 Copy/Paste/Delete
Ctrl-C
Insert key
Delete key
Copy selected data to internal clipboard
Insert clipboard as new session
Delete selection
4.3.6 Overlay shortcuts
Ctrl-V
Alt-O
Alt-H
Paste clipboard as overlay
Remove overlay
Scroll Overlay tool
4.3.7 Scrolling shortcuts
key
key
key
key
Page Up key
Page Down key
Home key
End key
Right-click in graph
Alt-H
Scroll graph to the right (earlier time)
Scroll graph to the left (later time)
Scroll graph up
Scroll graph down
Scroll graph by one window width left (later time)
Scroll graph by one window width right (earlier time)
Scroll graph to beginning of session
Scroll graph to end of session
Center active trace if magnified
Scroll Overlay tool
4.3.8 Magnifying shortcuts
Ctrl- key
Ctrl- k
 ey
Ctrl- k
 ey
Ctrl- k
 ey
Decrease time magnification
Increase time magnification
Increase vertical magnification
Decrease vertical magnification
© 2004 Innovate Technology, Inc.
32
4.3.9 Selection tricks
Click in graph and
drag
Shift-click in graph
Ctrl-click and drag
Remove all selections, select dragged-over range
Extend selection from first click to new click
Select dragged-over range without removing other selections. Ctrl-click in
a selection range removes that selection range.
© 2004 Innovate Technology, Inc.
33
5 Tips & Tricks for using LogWorks
The included log file example Autobahn.log shows a good example of using the features of
LogWorks to determine if a fueling change made a difference in power of the engine.
Let’s look at Session 1 and Session 3 in the example. Both are 3rd or 4th gear pulls from low RPM
to redline. We look at the run from 1300 RPM to 8400 RPM.
Session 1. Time between 1300 RPM and 8400 RPM is 28.18 sec
Session 3. Time between 1300 RPM and 8400 RPM is 27.93 sec
© 2004 Innovate Technology, Inc.
34
Now we are using the overlay tool to overlay session 3 over session 1:
What is immediately noticeable is that the AFRs of session 3 are higher than those of session 1 in
the area below 7000 RPM, but lower above. Let’s see how that affects power and acceleration.
Acceleration can be determined by the slope of the RPM curve. The steeper the slope, the higher
the acceleration and therefore power (assuming other conditions like weight and wind are the
same).
In area 1, acceleration is lower in session 3, while AFRs are higher than in session 1.
In area 2, both RPM slopes match. Therefore the AFR change had little effect.
In area 3, the RPM slope of session 3 is noticeably steeper. The engine made more power with
the leaner AFR.
In area 4, the RPM slope of session 3 is flatter. The engine made less power, but AFRs are richer
than in that area.
You can also see than when you compare the WOT rows in the charts of the session
Session 1
Session 3
You can see that the power curve can be improved by richening up the fields below ~4500 RPM
and leaned out in the fields at 7000 RPM and above.
© 2004 Innovate Technology, Inc.
35
6 Revision History
1.1
Initial release – April 28, 2004
© 2004 Innovate Technology, Inc.
36