Download Format PDF - TracenPoche

Transcript
Table des matières
1. Introduction................................................................................................................................................4
2. Présentation générale................................................................................................................................. 8
2.1 Fonctionnement du programme...........................................................................................................8
2.1.1 Interface....................................................................................................................................... 8
2.1.2 Boutons et clavier........................................................................................................................ 9
2.1.3 La structure du script................................................................................................................. 11
a) Les options.................................................................................................................................11
b) La syntaxe générale................................................................................................................... 13
c) Boutons de la zone script........................................................................................................... 14
2.1.4 Structure de la zone analyse...................................................................................................... 15
2.1.5 Boîte de dialogue transformations............................................................................................. 16
2.1.6 Premier exemple : construction d’un carré................................................................................17
Remarque importante : choix d'un objet parmi plusieurs sous la souris................................... 19
2.2 Les fonctions avancées du script....................................................................................................... 25
2.2.1 Les boucles................................................................................................................................ 25
a) La notion de boucle....................................................................................................................25
b) Quelques exemples de boucles.................................................................................................. 25
2.2.2 Les macro-constructions ou macros.......................................................................................... 26
a) La notion de macro.................................................................................................................... 26
b) Création d'une macro................................................................................................................. 27
c) Quelques précisions sur les macros........................................................................................... 28
2.2.3 Le mode pas à pas......................................................................................................................29
2.2.4 L'option changement état bloc................................................................................................... 31
2.2.5 L'objet VARSI et la fonction µ..................................................................................................32
a)Le principe.................................................................................................................................. 32
b)Syntaxe des conditions dans un VARSI..................................................................................... 33
c)Utilisation des VARSI................................................................................................................ 33
d)La fonction µ.............................................................................................................................. 35
e)Imbrication des VARSI...............................................................................................................36
2.2.6 L'objet PointAimante.................................................................................................................36
a)Principe....................................................................................................................................... 36
b)Les syntaxes................................................................................................................................36
2.3 TracenPoche et ses fichiers............................................................................................................... 39
2.3.1 Les différents fichiers................................................................................................................ 39
2.3.2 Structure du fichier base.tep...................................................................................................... 39
2.3.3 Structure d’un fichier figure...................................................................................................... 40
a) La section @enonce................................................................................................................... 40
b) La section @config....................................................................................................................40
c) Remarques particulières.............................................................................................................43
2.3.4 Sauvegarde et chargement......................................................................................................... 44
2.4 Le CD-ROM TracenPoche................................................................................................................ 45
2.4.1 Présentation du CD....................................................................................................................46
2.4.2 Installation du logiciel............................................................................................................... 46
2.4.3 Les menus de l'interface.............................................................................................................47
a)Le menu Fichier.......................................................................................................................... 47
b)Le Menu Edition.........................................................................................................................48
c)Le menu Affichage..................................................................................................................... 49
d)Le menu Outil.............................................................................................................................49
e)Le menu Aide..............................................................................................................................52
2.5 Le site : utilisation en ligne............................................................................................................... 52
TracenPoche ... la géométrie dynamique pour tous.
Page 2