Download Waveform Analyzer Manual

Transcript
Waveform Analyzer Manual
Contents
1 OVERVIEW ..................................................................................... 4
1.1 STARTING THE WAVEFORM ANALYZER ............................................. 4
1.2 WAVEFORM ANALYZER FILE FORMATS ............................................. 4
1.3 TIME UNITS .............................................................................. 5
1.4 CONNECTING A SIMULATION TO A TRACE .......................................... 5
1.5 CONNECTING A PATTERN TO A PORT ................................................ 7
1.6 CONNECTING IN PARALLEL ............................................................ 9
1.7 MEASURING TIME AND VALUE DIFFERENCES IN WINDOWS .................. 10
1.8 FINDING A SEQUENCE IN A TRACE OR PATTERN ................................ 10
1.9 GROUPING TRACE AND PATTERN WINDOWS..................................... 11
1.10 GENERATING PATTERNS ........................................................... 11
1.11 USING TRIGGERS.................................................................... 12
2 PATTERN GENERATION LANGUAGE .....................................................
2.1 USING THE PATTERN GENERATION LANGUAGE ................................
2.2 PGL STATEMENTS ....................................................................
2.3 FUNCTIONS IN PGL ..................................................................
2.4 WILD-CARD MATCHING IN PGL ...................................................
2.5 PGL SYNTAX ...........................................................................
14
14
15
16
17
18
3 WAVEFORM ANALYZER INTERFACE .....................................................
3.1 WAVEFORM ANALYZER TOOLBAR ICONS .........................................
3.2 TRACE/PATTERN WINDOW .........................................................
3.3 MENUS ..................................................................................
20
20
21
23
3.3.1
3.3.2
3.3.3
3.3.4
3.3.5
3.3.6
3.3.7
3.3.8
3.3.9
File menu ............................................................................................ 23
Edit menu ............................................................................................ 25
View menu........................................................................................... 25
Trace menu.......................................................................................... 26
Pattern menu ....................................................................................... 29
Script menu ......................................................................................... 32
Capture menu ...................................................................................... 32
Window menu ...................................................................................... 33
Help menu ........................................................................................... 34
4 INDEX ......................................................................................... 35
www.celoxica.com
Page 1