Download Cytoscape User Manual

Transcript
Cytoscape User Manual
Boolean Filter
The Boolean Meta-Filter allows you to define a new filter that is a logical combination of existing filters.
Available filters are displayed. By selecting one or more filters, you can then choose whether Nodes or
Edges pass “ALL” (AND), “AT LEAST ONE” (OR), or “ONLY ONE” (XOR) of the selected filters.
Once created, Boolean filters can then themselves be combined using the Boolean filter to create arbitrarily
complex logical combinations of filters. Note that unlike the String and Numerical Filters, Boolean filters
will need to be assigned a name manually.
Saving Filters
Filters are currently saved automatically in the filters.props file found in the .cytoscape directory, found
in each user's home directory. Once created, filters are saved for future sessions, as long as you exit Cytoscape normally via File → Quit (i.e. not via ctrl-c on Linux).
Running filters
Any available filter can be run by pressing the ‘Apply selected filter’ button. When a filter is applied to
your network and multiple nodes or edges are selected, all of the normal selection-related operations may
be performed, such as Delete Selected Node/Edges, Copy To New Network, and Invert Selection.
The Select Menu
The Select → Nodes and Select → Edges menus provide several mechanisms for selecting nodes and
edges. Most options are fairly straightforward; however, some need extra explanation.
Select → Nodes → By Name... selects nodes by the node identifier (ID). This is the value seen in the
leftmost column of the attribute browser. This does not change, even if the displayed node label changes!
Select → Nodes → From File... selects nodes based on node identifiers found in a specified file. The file
format is simply one node id per line:
Node1
Node2
Node3
...
120