Download Getting Started with Synergy/DE

Transcript
Developing Your Application in Workbench
Customizing Your Development Environment
Select the configuration
you want to modify
Select the tool you want to change
or click New to define your own tool
from scratch
Click the arrow key
to display a
selection list of
variables to help
you build your
desired command
line
Type the command
you want the
specified tool
to execute
Select Capture
output to capture
the command’s
output and process
it with Workbench’s
built-in error
message
processing facility.
(Do not check this
box for COM, Java,
or .NET projects)
Type or select the
directory from
which to run the
command. By
default, commands
are run from the
working directory
(%rw)
Select Output to
build window to
send captured
output to the build
window
Select Clear build window
to clear the contents of the
window before executing
the command
Select which files to
save before the
command is
executed
Select when the
entry will be
displayed on the
menu
Type the text that
will appear on the
Project menu as
the menu entry for
this tool. Indicate
the quick-select
character for the
entry by preceding
that character with
an ampersand (&)
Figure 2-18. Customizing compiling, building, and running commands.
All new projects of this type and configuration will inherit these tools when the project is created. If
a project type has more than one configuration, you will need to customize each configuration
individually.
Customizing commands for a file being edited outside a Synergy/DE project
You can customize the commands for compiling, building, debugging, and executing on a global
level when a .dbl file is opened with no open project or workspace.
1.
Close any open workspaces and files.
2.
From the Tools menu, select Options > File Extension Setup.
Getting Started with Synergy/DE 9.1.3 (3/08)
2-35