Download Utilisation de Flash MX

Transcript
2
Choisissez Fichier > Aperçu avant publication et sélectionnez, dans le sous-menu, le format de
fichier que vous souhaitez afficher.
Flash crée, avec les valeurs courantes de Paramètres de publication, un fichier du type spécifié
au même emplacement que celui du document Flash (FLA). Le fichier demeure à cet
emplacement tant qu’il n’est pas remplacé ou supprimé.
Utilisation du lecteur autonome
Le lecteur autonome lit les animations Flash exactement comme elles apparaissent dans un
navigateur web ou dans une application hôte ActiveX. Le lecteur autonome est installé avec Flash
(et nommé Flash Player autonome sous Windows et Flash Player sur le Macintosh). Lorsque vous
double-cliquez sur un fichier Flash, le système d’exploitation démarre le lecteur autonome qui, à
son tour, lance l’animation. Vous pouvez utiliser le lecteur autonome pour permettre aux
utilisateurs ne disposant pas d’un navigateur web ou d’une application supportant les contrôles
ActiveX d’afficher vos animations.
Vous pouvez contrôler les animations dans le lecteur autonome à l’aide des commandes de menu
ou de l’action FScommand. Par exemple, pour que le lecteur autonome s’affiche sur la totalité de
l’écran, vous affectez l’action FScommand à une image ou à un bouton, puis sélectionnez la
commande Fullscreen avec le paramètre true. Pour plus d’informations, consultez Utilisation
d’actions et de méthodes pour contrôler les clips, sous Aide > Utilisation de Flash.
Vous pouvez également imprimer des images de l’animation à l’aide du menu contextuel du
lecteur autonome. Pour plus d’informations, consultez Impression depuis le menu contextuel
de Flash Player, sous Aide > Utilisation de Flash.
Pour contrôler les animations depuis le lecteur autonome, choisissez une des options suivantes :
• Ouvrez un nouveau fichier ou un fichier existant en choisissant Fichier > Nouveau ou
Fichier > Ouvrir.
• Modifiez l’affichage de l’animation en choisissant Affichage > Zoom et, dans le sous-menu,
choisissez Tout afficher, Zoom avant, Zoom arrière ou 100 %.
• Contrôlez la lecture de l’animation en choisissant Contrôle > Lire, Rembobiner ou Boucle.
Configuration d’un serveur web pour Flash
Lorsque vos fichiers sont accessibles à partir d’un serveur web, ce dernier doit les identifier
correctement comme animations Flash Player pour pouvoir les afficher. Si le type MIME est
absent ou n’est pas correctement proposé par le serveur, il se peut que le navigateur affiche des
messages d’erreur ou une fenêtre vide comportant une icône représentant une pièce de puzzle.
Votre serveur est probablement déjà correctement configuré. Pour tester la configuration du
serveur, consultez la note technique 12696 sur le centre de support de Macromedia Flash à
www.macromedia.com. Si votre serveur n’est pas correctement configuré, vous (ou votre
administrateur système) devrez ajouter les types MIME pour Flash aux fichiers de configuration
du serveur et associer les types MIME suivants aux extensions des fichiers SWF :
• Le type MIME application/x-shockwave-flash porte l’extension .swf.
• Le type MIME application/futuresplash porte l’extension .spl.
Publication 443