Download User Manual
Transcript
Frequently Asked Questions (FAQ) 248 What can be done about this? Use the "Auto-open on Runtime" menu command from the File menu to tell SpecView to open (start) this GDW when entering Runtime Mode. Also when creating buttons to change screens use GDW Control: Swap to another GDW to swap to another GDW screen without closing it and clearing the trace line(s), instead of using GDW Control: Close this and Swap To GDW, which is intended for use with infrequently used GDW screens, such as setup screens that don't contain Trend Charts. How can a screen (GDW) be printed to an Adobe PDF (Portable Document Format) file? Firstly Adobe Acrobat (or another program that can create PDF files) needs to be installed on the PC. Then there are 2 ways of doing this: 1. By using either the Print or Print Setup menu commands from the File menu, because when Adobe Acrobat is installed it will be shown in the list of printers and can be selected to create a PDF (Portable Document Format) file. 2. If the File Menu is not available (because Full Screen mode is enabled), or if the printing is to be done from the Strategy Controller, then use the Printer Setup from Windows itself to set Adobe to be the 'Default Printer'. How can I make a Strategy Event which will keep 'firing' all the time that something is 'true'? Normally Strategy Events are edge-driven so that they only fire when a change occurs. Therefore in event that says, for example, "If Bool1 = On" will only fire once, and will only fire again if the Boolean goes to Off and then back to On. So if you want something to keep firing all the time, for example, while Bool1=On then do this: Add a Value Based Event called "Every 2 seconds", and watch SpecView.Time, choose 'Changed' & test against 00:00:02. In the Event Control panel check the Enable on Boolean & choose Bool1=True. This event will then 'fire' every 2 seconds all the time that Bool1=On. This is useful to, for example, make something blink/flash or repeatedly ring a bell all the time there is an Alarm. · How can I make something blink/flash on screen? - Add a Value Based Event called "Every second & while Alarm=On", and watch 'SpecView.Time', choose 'Changed' & test against 00:00:00. In the 'Event Control' panel check the 'Enable on Boolean' & choose 'Alarm=True'. (for the Alarm you want, or use SpecView.AnyAlarm for all alarms). - Set the Action to do a Math Function and subtract a Boolean User Variable rom itself and store the answer in itself, for example: Copy From: Bool1 Subtract: Bool1 Copy To: Bool1 (Subtracting a Boolean value from itself effectively toggles the value). - Also add a Value Based Event called "If Alarm = Off" to check if Alarm equals "Off". - Set the Action to set Bool1 to "Off". So that the Boolean is turned off when the Alarm is. Then select the item on the screen you want to flash & set the Color Dynamics using 'Edit->Color Dynamics'. - When "SpecView.Bool1 = On" set it to (maybe) red. - When "SpecView.Bool1 = Off" set it to white (if the background is white then it'll disappear) It is possible to stop the Alarm box appearing automatically by using: 'File->Preferences->Alarm tab' & unsetting 'Popup Enabled'. How can I position items on a screen & align them to within a pixel & stop them 'jumping' to the grid? This is done using by disabling the grid from the View Menu, by setting Grid Size to zero & unchecking Grid Lines. However, although this allows objects on the screen to be positioned manually to within one pixel, this requires very precise positioning of the mouse & so is not recommended. How can I make some text appear on the screen using the Strategy Controller when something happens? There are a number of different ways of doing this: - Make some text on the screen (GDW) appear/disappear using Color Dynamics (making the text the same colour as the background color will make it seem to disappear). - Swap the screen (GDW) to a screen with the text on it. Remember to put a button on the new screen to swap the screen back. - Use Run External Program to run a program such as Notepad to display a file containing the text. For example: c:\Windows\notepad.exe C:\SV32\Furnace\FurnaceWarning.txt (Change paths as appropriate) Copyright SpecView 1994 - 2007