Download Smart Network Building Blocks

Transcript
Dowslake Network Management
As a database which stores management information, a MIB is often
shown as a tree, where the nodes of the tree define the database and
Centralised Element Organiser (CEO)
its tables, rows and fields. The collection of all MIBs is organized in a
Centralised Element Organiser (CEO) is Dowslake’s new generation of
tree structure, where each node on the tree represents a single MIB.
network management. It provides a topology based network element
The SNMP MIB hierarchy is defined by RFC 1155 and RFC 1213.
management, allowing the administrator to centralise all information
MIBs fall into two categories:
from each network element connected in the network. In order to
Standard MIB: A standard MIB is defined by the IETF. An example of
keep cost down and operations simple, Dowslake provides 2 options
a standard MIB is RFC 1215, a convention for defining traps for use
to run CEO:
with the SNMP.
1) Using Master Node Controller as Management Server
Private MIB: A non-standard proprietary MIB is defined by an enter-
The Master NE’s powerful system controller provides a mySQL data-
prise, such as Dowslake Microsystems. The IETF assigns a unique
base which is used to collect information across the network for other
OID number to a company, under which they can define their own
Slave nodes. User can communicate with the Master node using a
OIDs for their specific products. Dowslake company OID is assigned
network terminal running a web browser. Through a Graphic User In-
as 16726. All MIBs for Dowslake equipment are defined under such
terface, user can see all the NEs in the network and click on any one
OID. As an example, Dowslake 10G carrier Ethernet switch MTS1080
of them for configuration and operations purpose. See page 5 CATS
SNMP agent contains following MIBs:
network management as an example.
- RFC 1155: Structure of Management Information (SMI)
Direct connection between user’s terminal and network Master node
- RFC 1212: Concise MIB definitions
is best suited for smaller and simple networks.
- RFC 1213: Management Information Base (MIB-II)
2) Client-Server Type Using External Dedicated Server
- RFC 1215: A convention for defining traps for use with the SNMP
When user needs to grow the network beyond hundreds of nodes, a
- Dowslake-Global-Reg: A private MIB, which represents the Dows-
more powerful client-server based management is necessary, reason
lake general product and MIB structures.
why CEO offers a second option which is to run the network manage-
- DOWSLAKE-NETWORK.mib: A private MIB, which specifies general
ment from a server. The network management server needs to be
OIDs for DowsLake’s Network products.
pre-configured to run Linux, and with enough hardware support such
- DOWSLAKE-MTSCommon-sys-mgmt.mib: A private MIB, which
as memory and hard drive. It allows to manage thousands of nodes
specifies MTS1080 system specific management objects OIDs.
populated with Dowslake equipment.
- DOWSLAKE-MTSCommon-dev-mgmt.mib: A private MIB, which
specifies MTS1080 device specific management objects OIDs.
For detailed SNMP and MIB information of each product, please refer
to the User Manual.
Graphic User Interface (GUI) for Element Control
The majority of Dowslake products also comes with Java based GUI
for individual equipment control. It allows user to simply connect to
the equipment and monitor/change alarms, parameters and operation modes. Below shows a Java GUI interface example for Dowslake
10G switch MTS1080. With GUI user can visualise port status, set
parameters, or monitor alarms at a simple click of mouse.
Master Controller & Server Specifications
Management Server (by Default it is the Master Controller)
DataBase
OS
North-Bound
Terminal HW
Max. # of Nodes
MySQL V 4.0.23a
Linux V 2.6.14.2
Windows XP or Windows Professional type
min. Intel Pentium 1G Memory, 40G Hard Drive
Up to 180
External/Backup Server for Higher # of Nodes or for Backup
Hardware
OS
Min. Free RAM
Database
Max. # of Nodes
min. Pentium 2.0G, RAM 2.0G, 10G HD
Linux SuSE 8.2(Kernal 2.4.20)
600 M
MySQL 4.0.21
> 1500
Network Management Hardware
MNGT Port
In-band
Remote Upgrade
2
10/100M Ethernet RJ45
Yes for Access Cards or using OSC
Yes