Download ARCHIVE 3035

Transcript
ComputorEdge
8/31/12
File associations affect which program will run when you double-click on a certain type of file. If it is a data file such as .txt or .
doc it is natural to associate it with opening an editor or word processor. The .cmd is an executable file associated with the
Windows operating system. When you double-click the file, it goes into an execution mode, not editing. That's why you have
a separate Edit option in the right-click menu. If you were to actually associate .cmd files with opening LibreOffice, those files
would no longer run as designed.
It wouldn't be wise to edit command files with LibreOffice unless you're careful to always save it as a pure text file. A better
option would be Notepad++ (notepad-plus-plus.org/) which is a much more powerful text (program) editor than Notepad
and will appear in your ".cmd" right-click menu ("Edit with Notepad++") after installation.
To get to the file association settings in Windows XP open Windows Explorer and select Tools => Folder Options => File
Types tab (see Figure 1).
Figure 1. Folder Options window with File Types tab open in Windows XP.
If you really want to associate editing .cmd files with LibreOffice, then you will need to enter the Advanced option at the
bottom of the tab with "CMD" selected. (If CMD is not on the list, you may need to add it as new.) After you click Advance,
you will see the Edit File Type window shown in Figure 2.
6 of 41