Download SUSE Linux Enterprise Desktop

Transcript
Die Registrierungsdatei enthält außerdem die beiden Variablen watch-port-tcp
und description. watch-port-tcp koppelt die SLP-Dienstankündigung
daran, ob der entsprechende Dienst aktiv ist, indem slpd den Status des Diensts
überprüft. Die zweite Variable enthält eine genauere Beschreibung des Diensts,
die in den entsprechenden Browsern angezeigt wird.
Statische Registrierung über /etc/slp.reg
Der einzige Unterschied zwischen dieser Methode und der Prozedur mit /etc/
slp.reg.d besteht darin, dass alle Dienste in einer zentralen Datei gruppiert
sind.
Dynamische Registrierung über slptool
Wenn ein Dienst dynamisch ohne Verwendung von Konfigurationsdateien registriert
werden soll, verwenden Sie das Kommandozeilenprogramm slptool. Dasselbe
Programm kann auch die Registrierung eines bestehenden Dienstangebots aufheben,
ohne slpd neu zu starten.
21.5 Weiterführende Informationen
Weitere Informationen zu SLP finden Sie in folgenden Quellen:
RFC 2608, 2609, 2610
RFC 2608 befasst sich mit der Definition von SLP im Allgemeinen. RFC 2609
geht näher auf die Syntax der verwendeten Dienst-URLs ein und RFC 2610 thematisiert DHCP über SLP.
http://www.openslp.org/
Die Homepage des OpenSLP-Projekts.
/usr/share/doc/packages/openslp
Dieses Verzeichnis enthält alle verfügbaren Dokumentationen zu SLP, einschließlich
einer README.SuSE-Datei mit Details zu SUSE Linux Enterprise Desktop, der
oben genannten RFCs und zweier einleitender HTML-Dokumente. Programmierer,
die an den SLP-Funktionen interessiert sind, finden weitere Informationen im
Programmierhandbuch, das im Paket openslp-devel enthalten ist.
316
Verwaltungshandbuch