Download Display - Siemens
Transcript
Configuring in ProTool Proceed As Follows To compile and transfer the finished project, do the following: 1. Choose the menu option File → Compile as normal in ProTool. 2. Make sure that in the Compilation Settings dialog box all options are selected (this is not absolutely necessary if no changes have been made in a particular category since the last compilation run). 3. As normal in ProTool, choose the menu option File → Download. The diagnosis-compatible project is now on the operating unit. 5.1.9 Quick Test of Minor Changes to an S7-PDIAG Project (S7-PDIAG Version 5.0 or Higher) In S7–PDIAG version 5.0 or higher network data relevant to diagnosis can be stored direct in the PLC (DiagDataInAS mode). If you operate S7–PDIAG in this mode (menu option Tools → Settings → Compile, check box Apply network data relevant to diagnosis to AS active), you can see direct how minor changes in your S7–PDIAG project affect the ProTool project. The ProTool configuration does not have to be recompiled and re-downloaded onto the operating unit for this. This can save you a lot of time, particularly during the commissioning phase. Note Prior to final commissioning of the modified S7–PDIAG project you should carry out a final compilation of the ProTool configuration and download it to the operating unit to ensure correct functioning of the operating unit. When Can You Use DiagDataInAS Mode? Testing the following changes in the S7–PDIAG configuration does not require recompilation and re-downloading in ProTool: • adding or removing operands in monitored networks • changing the network logic or the operators in monitored networks • changing the monitoring time In these cases it is sufficient to recompile your S7–PDIAG configuration and reload the PLC. The operating unit then reads the modified operands, operators or monitoring times direct from the PLC. Synchronization with the STEP 7 database is not required for this data. 5-24 User's Manual ProAgent for OP Release 07/00