Download Using the Electric VLSI Design System

Transcript
Chapter 4: Display
The Simulators Preferences (in menu File / Preferences..., "Tools" section, "Simulators" tab), offers some
controls for built−in simulators.
• "Auto advance time" requests that the main time cursor advance after each stimulus is added. This
allows each stimulus added to occur at a new time.
• "Resimulate each change" requests that the simulator rerun the simulation after any change to the
stimuli. Because the process of simulating a circuit can be costly, you might want to delay
resimulation until all stimuli have been set. If you uncheck this item, you must issue the Update
Simulation Window command to re−run the simulation.
Other Controls
At the top of the waveform window, above the signal names, are many useful controls. Those relating to time
have already been discussed. Here are the remaining buttons:
• "Refresh"
Rereads the simulation output file and updates the display. If the simulation has
been re−run, and the output file is different, then this button shows the new data. This function is also
available with the Refresh Simulation Data command (in menu Window / Waveform Window).
• "Show Vertices"
Controls the display of dots on the vertices of the waveforms. The
button toggles between three states: (1) showing lines only, (2) showing lines and dots, and (3)
showing dots only. This is only available for analog waveforms: digital signals are always drawn
with lines. These functions are also available with the Show Points and Lines, Show Lines, and
Show Points commands (in menu Window / Waveform Window).
• "Show Grid"
Displays a grid in the waveform panels. The button toggles between showing
and not−showing the grid. This function is also available with the Toggle Grid Points command (in
menu Window / Waveform Window).
• The Panel popup This is a list of all panels, including the hidden ones. Selecting a panel from this
list toggles its "hidden" state, making a visible one disappear, and making a hidden one reappear.
• "Grow" and "Shrink"
These buttons, which show a waveform being stretched or
squeezed, cause the minimum panel size to change. These functions are also available with the
Increase Minimum Panel Height and Decrease Minimum Panel Height commands (in menu
Window / Waveform Window). By shrinking the panel size, more of them can fit in the window
without having to use a slider to access them. Also, the panels can be resized individually by
dragging any of the dividers.
Plotting can be done with special commands in the Window / Waveform Window submenu (see Section
4−8 for more on printing).
An analog signal can be converted to digital with the command Generate Digital Signal from Analog
Signal (0.5v threshold) (in menu Window / Waveform Window).
Using the Electric VLSI Design System, version 9.04
143